HALE Schema Transformation Plug-in for FME

With the HALE Schema Transformation Plug-in for FME you can execute HALE schema transformations from a FME workspace, e.g. to use the schema transformation to produce complex XML or GML based on a specific schema. It was developed by Fraunhofer in cooperation with Safe Software.

See the HALE Plug-in for FME user guide for information on how to work with the plug-in in FME.

Installation

Prerequisites

The plug-in is compatible with FME 2014 and FME 2015. Apart from FME you need a Java installation and at least HALE 2.6 (newest version recommended) on your machine.

Installer (Windows)

Download the plug-in installer here:

During the installation you will be asked to agree to the
License Agreement for the HALE Schema Transformation Plug-in for FME. Install the plug-in to your FME program folder.

Manual install

Please read the License Agreement for the HALE Schema Transformation Plug-in for FME. With the download of the plug-in archive provided here you agree to the license agreement:

To install the plug-in in FME, simply extract the formatsinfo, metafile and plugins folders from the plug-in archive into your FME program folder.

FAQ

I get the message "Error creating project" when first running HALE from FME
  • Make sure the HALE project file name in the writer settings has an extension that is recognized by HALE as project file (.halex or .hale). HALE needs to be able to determine the project type to created it.

license.txt - License Agreement HALE Plug-in for FME (5.5 kB) Simon Templer, 01/08/2014 04:19 pm

license.pdf - License Agreement HALE Plug-in for FME (PDF Version) (102.3 kB) Simon Templer, 01/08/2014 04:19 pm